Debian Lenny

Porque usar a Debian? A Debian é a distribuição que mais cresce no mundo, cada versão é somente lançada após rigorosos testes de segurança e correção de falhas fazendo desta a mais segura e confiável dentre todas as outras distribuições Linux. É reconhecida como a mais segura, maior e atualizada mais freqüentemente entre as outras distribuições Linux, além de ser a única sem fins comerciais. É a única que adota o estilo de desenvolvimento aberto e não é mantida por uma empresa comercial (note que o endereço do WebSite da Debian termina com .org), ao invés disso é mantida por programadores, hackers e especialistas de segurança espalhados ao redor do mundo, seguindo o estilo de desenvolvimento do Linux.

Download Debian Lenny

O download do Debian pode ser feito diretamente do site www.debian.org. Estaremos utilizando a versão para plataforma I386.

Debian-ISO
Download da Imagem Debian Lenny

Instalação

A instalação do Debian é muito simples, mas precisamos seguir algumas recomendações  para otimizar o sistema e deixá-lo pronto para a instalação do Asterisk e outros pacotes necessários.

1. Certifique-se que os dispositivos que não serão utilizados estejam desabilitados na BIOS do seu servidor (Porta Serial, Porta Paralela e etc). Apenas deixe os que realmente serão utilizados, caso utilize teclado USB deixe o mesmo habilitado em sua BIOS. Isso irá previnir conflitos de IRQ no futuro quando necessitar instalar placas de telefonia(Digium, Sangoma, Digivoice, Khomp e outras).

2. Instalação apenas em modo Texto. Quando instalarmos o sistema operacional iremos apenas escolher a opção de “Sistema Básico”, ou seja, faremos uma instalação limpa sem ambiente gráfico e outros serviços, isso fará com que não tenhamos que compartilhar recursos do S.O com a telefonia uma vez que todo o processamento de voz está centralizado no processador da máquina.

Video Aula – Instalação

Agora chegou a melhor hora, colocar a mão na massa! Acompanhe a video aula de instalação do sistema operacional Debian a seguir:

Instalação e atualização dos pacotes necessários

Conforme acompanhamos em nossa video aula precisamos fazer as atualizações de Kernel e instalação dos pacotes necessários para a compilação e funcionamento do Asterisk.

Comando:

apt-get install bison ncurses-dev libssl-dev libnewt-dev zlib1g-dev initrd-tools cvs procps libgraphics-magick-perl libgraphicsmagick++1 libgraphicsmagick++1-dev libgraphicsmagick1 libgraphicsmagick1-dev libtiff-doc libtiff-opengl libtiff-tools libtiff4 libtiff4-dev libtiffxx0c2 openssl procps bison libtool libedit2  php5-mysql libedit-dev libeditline-dev libeditline0 libnewt-dev libncurses5 libncurses-dev autoconf automake subversion make gcc g++ libxml2 libxml2-dev mysql-server-5.0 mysql-client libmysqlclient15-dev pciutils apache2 libapache2-webauth libapache2-mod-php5 php5-cli mpg123 unzip php5-mysql iptraf sendmail-bin sendmail php5-cli sharutils linux-headers-`uname -r` sysvconfig sox mysql-connector-odbc unixODBC unixODBC-devel libtool-ltdl-devel libtool-ltdl

apt-get update

Pronto, nossa instalação está completa!

Mestre Asterisk | Treinamento Parte 3

Creative Commons License
Treiamento Asterisk Grátis by Mestre Asterisk is licensed under a Creative Commons Atribuição-Uso Não-Comercial-Compartilhamento pela mesma Licença 2.5 Brasil License.

Related Posts with Thumbnails

88 Comentarios para “Instalação Debian Lenny | Parte 2”

  1. Parabens cara Muito bom mesmo …

    Só uma observação, para um usuario iniciate o VI nativo pode ser muito complicado entao pode-se intalar uma atualização do VI que eu acho ate mais facil de opera com o comando:

    apt-get install vim

    ou ate mesmo usar o NANO para a edição dos arquivos que é mais facil ainda.

    parabens novamente pelo trabalho…

  2. Poderia ser também.

  3. Salve Mestre, Hoje comecei a por em pratica seu ensinamento e mim deparei com o seguinte erro no meu LAB:

    Creating /etc/mail/sendmail.cf…
    *** ERROR: FEATURE() should be before MAILER()
    *** MAILER(`local’) must appear after FEATURE(`always_add_domain’)*** ERROR: FEATURE() should be before MAILER()
    *** MAILER(`local’) must appear after FEATURE(`allmasquerade’)*** ERROR: FEATURE() should be before MAILER()

    Creating /etc/mail/submit.cf…
    Informational: confCR_FILE file empty: /etc/mail/relay-domains
    Warning: confCT_FILE source file not found: /etc/mail/trusted-users
    it was created
    Informational: confCT_FILE file empty: /etc/mail/trusted-users
    Warning: confCW_FILE source file not found: /etc/mail/local-host-names
    it was created
    Warning: access_db source file not found: /etc/mail/access
    it was created
    Updating /etc/mail/access…
    Linking /etc/aliases to /etc/mail/aliases
    Updating /etc/mail/aliases…
    /etc/mail/aliases: 13 aliases, longest 10 bytes, 142 bytes total

    Warning: 3 database(s) sources
    were not found, (but were created)
    please investigate.

    Warning: These messages were issued while creating sendmail.cf
    make sure they are benign before starting sendmail!

    Errors in generating sendmail.cf
    *** ERROR: FEATURE() should be before MAILER()
    *** MAILER(`local’) must appear after FEATURE(`always_add_domain’)*** ERROR: FEATURE() should be before MAILER()
    *** MAILER(`local’) must appear after FEATURE(`allmasquerade’)*** ERROR: FEATURE() should be before MAILER()

    Starting Mail Transport Agent (MTA): sendmail.
    Configurando sensible-mda (8.14.3-5) …
    Configurando sendmail (8.14.3-5) …
    Configurando xinetd (1:2.3.14-7) …
    Stopping internet superserver: xinetd.
    Starting internet superserver: xinetd.

    esse seria um erro comum??? ele deu apois a instalação da dependencias…
    desde ja Agradecido!!!

  4. Esse erro ocorre pq você não possui um dominio valido de cara para internet, ou seja, quando instalamos o debian ele solicita o domain.
    No meu caso seria mestreasterisk.com.br, esse é um dominio valido para meu servidor.

    Como a maioria dos provedores de email não aceitam envio de mensagem sem autenticação pode ser que quando tentar enviar o recado deixado na sua caixa posta por email vai dar erro.
    Alguns provedores aceitam envio sem autenticação mais é a minoria.

    Teste o envio de email com esse comando no prompt do linux e ele retornara se o envio foi com sucesso ou não.

    sendmail -v -f luanyata@gmail.com < /root/teste.txt

    Att,

  5. Bom Dia!!!

    a o tentar enviar o email de teste ele retorna a seguinte msg:

    Recipient names must be specified (Nomes dos destinatários deve ser especificado)

    “/

  6. Aqui estou usando o vmware workstation 7

    Corrigindo
    Pode colar o apt-get install com todos os pacotes, conforme procedimento feito na parte 3 deste tutorial.

    Para ter suporte a Fax teremos que instalar SPANDSP (e suas dependencias):

    apt-get install libgraphics-magick-perl libgraphicsmagick++1 libgraphicsmagick++1-dev libgraphicsmagick1 libgraphicsmagick1-dev libtiff-doc libtiff-opengl libtiff-tools libtiff4 libtiff4-dev libtiffxx0c2

  7. Mestre, instalei o Debian normalmente , porém ele assumiu um IP 10.0.2.15 , nada a ver com minha rede interna da maquina windows(192.168.254.x), estou pingando normalmente nos sites , porém no putty não consiguo acessar o servidor virtual , por que?

    aguardo sua resposta,

    Obrigado.

    Márcio Lima.

  8. Se você tem um servidor DHCP na sua rede interna deve fazer o seguinte:

    - Desligue sua máquina virtual
    - Na aba Detalhes do lado esquerdo clique no icone de rede
    - Abrirá uma nova tela de Configurações
    - No parametro Conectado a: escolha a opção: Placa em modo Brigde
    - Inicie novamente sua máquina virutal e execute o comando ifconfig para verificar se o novo IP é proveniente do seu servidor DHCP

    Isso é tudo,

    Att,

  9. Olá MestreAsterisk, estou iniciando a instalação seguindo o artigo, mas não estou localizando o apt-get install com todos os pacotes necessários que foi falado na video-aula….

  10. O Post já está atualizado…

    Da uma olhada por lá…

    Abs

  11. Agora!!! valeu mesmo, quando chegar no trabalho amanhã vou re-começar…

  12. Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    Nota, selecionando libncurses5-dev ao invés de ncurses-dev
    E: Impossível achar pacote initrd-tools

    Tá mostrando esta mensagem quando aplico o apt-get com todos os pacotes.

    não consegui ainda…

  13. Paulo Nunes,
    eu estava montando o laboratório do asterisk em cima do CentOS, e consegui baixar todos os pacotes necessários para a instalação, mas agora to usando ubuntu aqui com os repositórios do Debian e tb nao estou conseguindo achar alguns pacotes, tais como:

    mysql-connector-odbc unixODBC-devel unixODBC-devel libtool-ltdl-devel ncurses-dev initrd-tools libncurses-dev

    estou tentando aqui pegar esses mesmos pacotes la do centOS e compilalo-los para .deb
    se vc ou alguem souber de alguma outra forma de conseguir esses pacotes, seria de grande ajuda, vou tentando aqui preparar esses pacotes, qualquer coisa tamo ae
    Mestre Asterisk, poderia ajudar a gente?
    tb postei um comentario na parte de criação de CDR’s, gostaria da sua ajuda..vlww

  14. Enemy

    Para instalação do Asterisk no Ubuntu instale esses pacotes:

    sudo apt-get install bison festival festival-dev libssl-dev zlib1g-dev libnewt-dev make libtool

    sudo apt-get install libvorbis-dev automake mysql-server mysql-client mysql-admin libmysqlclient15-dev

    sudo apt-get install php5 php5-cli php5-common php5-dev curl libgnutls26 libgnutls-dev libtiff4-dev

    sudo apt-get install libasound2-dev libportaudio-dev libportaudio2 jackd

    sudo apt-get install unixodbc unixodbc-bin unixodbc-dev speex libspeex-dev

    sudo apt-get install libbluetooth-dev

    sudo apt-get install g++

    Depois escreve aqui para passar um feedback….

    Abs

  15. Olá Mestre Asterisk!!!
    ao instalar os pacotes deu algum erro, pode por favor me ajudar?

    apt-get install bison ncurses-dev libssl-dev libnewt-dev zlib1g-dev initrd-tools cvs procps libgraphics-magick-perl libgraphicsmagick++1 libgraphicsmagick++1-dev libgraphicsmagick1 libgraphicsmagick1-dev libtiff-doc libtiff-opengl libtiff-tools libtiff4 libtiff4-dev libtiffxx0c2 openssl procps bison libtool libedit2 php5-mysql libedit-dev libeditline-dev libeditline0 libnewt-dev libncurses5 libncurses-dev autoconf automake subversion make gcc g++ libxml2 libxml2-dev mysql-server-5.0 mysql-client libmysqlclient15-dev pciutils apache2 libapache2-webauth libapache2-mod-php5 php5-cli mpg123 unzip php5-mysql iptraf sendmail-bin sendmail php5-cli sharutils linux-headers-`uname -r` sysvconfig sox mysql-connector-odbc unixODBC unixODBC-devel libtool-ltdl-devel libtool-ltdl
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    O pacote bison não está disponível, mas é referenciado por outro pacote.
    Isto pode significar que o pacote está faltando, ficou obsoleto ou
    está disponível somente a partir de outra fonte
    E: O pacote bison não tem candidato para instalação

    desde já Agradeço!!

  16. Juliana,

    Retire o pacote bison da lista e tente novamente.

    Me fale se deu certo.

    Abs,

  17. Olá Mestre Asterisk!!!
    Não deu certo,pois quando eu tiro o pacote bison,dá problema no próximo,quando eu tiro o próximo,dá problema no próximo e assim sucessivamente.
    Sabe onde pode está o problema?
    Desde já agradeço!!!

  18. esses pacotes não são encontrados
    mysql-connector-odbc unixODBC-devel libtool-ltdl-devel unixODBC-devel libtool-ltdl-deel libtool-ltdl

  19. Mestre!

    Estou tenho problemas com a instalação.
    Estou seguindo todos os seus passos, estou usando o Lenny, tudo certinho!

    Para instalar o “initrd-tools” usei os repositórios do etch, pois no lenny não achava…

    mas alem disso, não consegui repositórios que tivessem os pacotes: “mysql-connector-odbc”, “unixODBC-devel”, “libtool-ltdl-devel” e o “libtool-ltdl”.

    Alguém tem alguma idéia??

    Abraços!

  20. Fernando Mota says:

    Mestre

    Bom dia

    Estou com problemas para fazer as instalações dos pacotes necessários para a configuração do Asterisk. Dos comandos que você menciona acima, eu já não consigo passar do ” initrd-tools “, me traz essa mensagem de erro “E: Impossível achar pacote initrd-tools”. O que devo fazer neste caso? Existe uma configuração mais atualizada desses pacotes?

    Agradeço

    Abs

    Fernando Mota

  21. 1. O unixodbc:

    http://www.unixodbc.org/

    Na seção downloads, baixe a ultima versão

    2. E o mysql-conector-odbc:

    http://www.mysql.com/products/connector/odbc/

    3. Copie o arquivo unixODBC-2.2.11.tar.gz para /:

    # cp /diretorio_de_download/unixODBC-2.2.11.tar.gz /

    4. Instale o pacote:

    # tar zxvf unixODBC-2.2.11.tar.gz
    # cd unixODBC-2.2.11/
    # ./configure
    # make
    # make install

    5. Faça o mesmo procedimento com o mysql-connector-odbc-3.51.12.tar.gz:

    # cp /diretorio_de_download/mysql-connector-odbc-3.51.12.tar.gz /
    # cd mysql-connector-odbc-3.51.12
    # ./configure
    # make
    # make install

    6. Libtool execute: apt-get install libcrypto++-dev libguile-ltdl-1 libltdl3 libltdl3-dev libtool-doc libtoolbar-java libtoolkit-perl libtool

  22. 1. O unixodbc:

    http://www.unixodbc.org/

    Na seção downloads, baixe a ultima versão

    2. E o mysql-conector-odbc:

    http://www.mysql.com/products/connector/odbc/

    3. Copie o arquivo unixODBC-2.2.11.tar.gz para /:

    # cp /diretorio_de_download/unixODBC-2.2.11.tar.gz /

    4. Instale o pacote:

    # tar zxvf unixODBC-2.2.11.tar.gz
    # cd unixODBC-2.2.11/
    # ./configure
    # make
    # make install

    5. Faça o mesmo procedimento com o mysql-connector-odbc-3.51.12.tar.gz:

    # cp /diretorio_de_download/mysql-connector-odbc-3.51.12.tar.gz /
    # cd mysql-connector-odbc-3.51.12
    # ./configure
    # make
    # make install

    6. Libtool execute: apt-get install libcrypto++-dev libguile-ltdl-1 libltdl3 libltdl3-dev libtool-doc libtoolbar-java libtoolkit-perl libtool

  23. mestre para min faltou instalar os seguintes pacotes: libtool-ltdl-devel libtool-ltdl initrd-tools mysql-connector-odbc unixODBC-devel.

    como faço para baixar todos eles usando apenas comandos via ssh…

    tem como me passar mastigadinho ? sou iniciante em linux!

  24. Marciano,

    Eu ja escrevi sobre isso em outro comentario, mas vou colocar aqui mais uma vez.

    Veja se ajuda.

    Att,

    1. O unixodbc:

    http://www.unixodbc.org/

    Na seção downloads, baixe a ultima versão

    2. E o mysql-conector-odbc:

    http://www.mysql.com/products/connector/odbc/

    3. Copie o arquivo unixODBC-2.2.11.tar.gz para /:

    # cp /diretorio_de_download/unixODBC-2.2.11.tar.gz /

    4. Instale o pacote:

    # tar zxvf unixODBC-2.2.11.tar.gz
    # cd unixODBC-2.2.11/
    # ./configure
    # make
    # make install

    5. Faça o mesmo procedimento com o mysql-connector-odbc-3.51.12.tar.gz:

    # cp /diretorio_de_download/mysql-connector-odbc-3.51.12.tar.gz /
    # cd mysql-connector-odbc-3.51.12
    # ./configure
    # make
    # make install

    6. Libtool execute: apt-get install libcrypto++-dev libguile-ltdl-1 libltdl3 libltdl3-dev libtool-doc libtoolbar-java libtoolkit-perl libtool

  25. JULIANA!

    Ocorreu o mesmo problema comigo quando estava usando internet 3g em ksa. mais quando instalei no trabalho q é internet a cabo eu consegui normalmente.

  26. Parabéns pelo site e pelas vídeo aulas, mas o comando apt-get não acha vários pacotes, e vi que os pacotes da vídeo aula com os pacotes desse artigo estão diferentes, tem possibilidade de adicionar outras fontes para que o apt-get funcione automático igual da video aula, porque fiz tudo igual na video aula, comentei a linha pra tirar a fonte do cd mas mesmo assim vários pacotes não são encontrados. Eu tiro um, ele pede outro, eu tiro mais uns dois ele pede mais uns 3. Desde já agradeço pela ajuda. Obrigado

  27. Estou postando aqui para agradeçer a este otimo treinamento que tem me ajudado muito, começei a me intereçar por sistemas VOIP em GNU/Linux a pouco e estou aprendendo de uma forma um tanto autodedata.

    Mestre sou novato tanto em Asterisk quando no ambiente GNU/Linux, estou rodando o Debian somente texto no Virtualbox, como faço para baixar estes pacotes e instalos nesta maquina?

    Desde já agradeço.

  28. Wagner

    Da uma olhada no treinamento la tem os pacotes a serem instalados.

    Treinamento Asterisk Grátis

    Abs

  29. Lendo informação de estado… Pronto
    0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
    Renovatiolab:~# apt-get install bison ncurses-dev libssl-dev libnewt-dev zlib1g-dev cvs procps libgraphics-magick-perl libgraphicsmagick++1 libgraphicsmagick++1-dev libgraphicsmagick1 libgraphicsmagick1-dev libtiff-doc libtiff-opengl libtiff-tools libtiff4 libtiff4-dev libtiffxx0c2 openssl procps bison libtool libedit2 php5-mysql libedit-dev libeditline-dev libeditline0 libnewt-dev libncurses5 libncurses-dev autoconf automake subversion make gcc g++ libxml2 libxml2-dev mysql-server-5.0 mysql-client libmysqlclient15-dev pciutils apache2 libapache2-webauth libapache2-mod-php5 php5-cli mpg123 unzip php5-mysql iptraf sendmail-bin sendmail php5-cli sharutils linux-headers-`uname -r` sysvconfig sox mysql-connector-odbc unixODBC unixODBC-devel libtool-ltdl-devel libtool-ltdl
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    Nota, selecionando libncurses5-dev ao invés de ncurses-dev
    procps já é a versão mais nova.
    procps já é a versão mais nova.
    libedit2 já é a versão mais nova.
    libncurses5 já é a versão mais nova.
    Nota, selecionando libncurses5-dev ao invés de libncurses-dev
    libxml2 já é a versão mais nova.
    pciutils já é a versão mais nova.
    E: Impossível achar pacote mysql-connector-odbc
    Renovatiolab:~#

  30. Possui um script mais atual destes pacotes ??

    Grato,

    Estou me interessando por esta tipo de tecnologia!!

    At.

  31. Pessoal…

    a sources.list do Debian Lenny contem quase todos os pacotes necessários para a instalação o q só falta é o initrd-tools onde não iram achar pois ele foi substituido pelo initramfs-tools, então é só inclui-lo no momento da instalação e atualização dos pacotes…

    apt-get install bison ncurses-dev libssl-dev libnewt-dev zlib1g-dev cvs procps libgraphics-magick-perl libgraphicsmagick++1 libgraphicsmagick++1-dev libgraphicsmagick1 libgraphicsmagick1-dev libtiff-doc libtiff-opengl libtiff-tools libtiff4 libtiff4-dev libtiffxx0c2 openssl procps bison libtool libedit2 php5-mysql libedit-dev libeditline-dev libeditline0 libnewt-dev libncurses5 libncurses-dev autoconf automake subversion make gcc g++ libxml2 libxml2-dev mysql-server-5.0 mysql-client libmysqlclient15-dev pciutils apache2 libapache2-webauth libapache2-mod-php5 php5-cli mpg123 unzip php5-mysql iptraf sendmail-bin sendmail php5-cli sharutils linux-headers-`uname -r` sysvconfig sox mysql-connector-odbc unixODBC unixODBC-devel libtool-ltdl-devel libtool-ltdl initramfs-tools

  32. Rodrigo Monte says:

    Olá Mestre, boa Tarde
    Estou instalando o asterisk no ubuntu 9.10. e depois que eu li o comentário do enemy100 acabei trocando aqueles comandos no começo do post pelo que vc colocou na resposta, e foi instalados todos ok.
    Valeu, muito obrigado por nos ajudar!

  33. Eduardo A. B. says:

    Olá Mestre,
    Gostaria que Publica-se um vídeo tutorial de como instalar o Meucci Be da Digivoice em uma máquina virtual. Tipo Virtual Box, estou apanhando muito aqui pra acessá-lo via rede, até q a instalação não tem muito secredo.
    Desde já agradeço sua atenção e comprienssão.
    Atenc.
    Eduardo

  34. Olá Mestre e pessoal,

    Estou tentando instalar os comando:mysql-connector-odbc unixODBC unixODBC-devel libtool-ltdl-devel libtool-ltdl
    porém, sem sucesso..

    tentei o procedimento de baixar o obdc e o mysql e tudo mais, mas nao estou conseguindo.
    No OBDC quando dou o comando “make” ele fica como se estivesse em um loop infinito tentando instalar, e nao termina…logo nao consiguo instalar o mysql commando..

    Será que alguem pode me ajudar neste caso?!

  35. tenho uma certa dificuldade ao dar o apt-get pois não consigo instalar os fontes :

    Nota, selecionando libncurses5-dev ao invés de ncurses-dev
    procps já é a versão mais nova.
    procps já é a versão mais nova.
    libedit2 já é a versão mais nova.
    libncurses5 já é a versão mais nova.
    Nota, selecionando libncurses5-dev ao invés de libncurses-dev
    libxml2 já é a versão mais nova.
    pciutils já é a versão mais nova.
    E: Impossível achar pacote mysql-connector-odbc
    scraipt:~#

  36. # apt-get install sendmail-bin sendmail php5-cli openssl procps bison libtool libedit2 libeditline0 libnewt-dev libncurses5 libncurses-dev autoconf automake subversion cvs libssl-dev make gcc g++ libxml2 libxml2-dev mysql-server-5.0 mysql-client libmysqlclient15-dev apache2 libapache2-webauth libapache2-mod-php5 php5-cli mpg123 php5-mysql libedit-dev libeditline-dev unzip php5-mysql tcpdump linux-headers-`uname -r` sysvconfig sox pciutils xinetd

    achei esse apt-get em um forum e até agora está indo !

  37. Ótimo blog, ótimos tutoriais.. muito bem explicado, até pra quem não entende nada de Linux como eu.

    Porém, ainda assim encontrei alguns problemas.. na próxima etapa do tutorial, recebi a mensagem “You do not appear to have the sources for the 2.6.26-2-686 kernel installed.” ao tentar compilar o ‘dahdi-linux’ e os outros..

    Pelo que li o problema foi com o linux-headers.. então executei “apt-get install linux-headers-2.6.26-2-686″ e os próximos passos funcionaram.

    É isto mesmo que devo fazer ? Muito obrigado pela ajuda.

  38. Olá Mestre,

    Acho que você excluiu minha pergunta, mas eu vou faze-la denovo e eficarei agradecido se vc responda pois eu travei nesta parte.

    Como eu baixo os pacotes odbc e e my sql não estao sendo achados pelo debian na hora de instalar os pacotes, então como eu coloco os pacotes dentro do debian em modo texto (conforme o tutorial eu nao intalei a parte grafica), eu sou novato em linux então não sei navegar na internet em modo texto e fazer o download, teria como fazer o download pelo hospedeiro (opensuse 11.2) e passar para a maquina virtual?
    Abaixo segue minha mensagem de erro:

    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    Nota, selecionando libncurses5-dev ao invés de ncurses-dev
    procps já é a versão mais nova.
    procps já é a versão mais nova.
    libedit2 já é a versão mais nova.
    libncurses5 já é a versão mais nova.
    Nota, selecionando libncurses5-dev ao invés de libncurses-dev
    libxml2 já é a versão mais nova.
    pciutils já é a versão mais nova.
    E: Impossível achar pacote mysql-connector-odbc

  39. Jair,

    Nos comentários deste post, eu coloquei como fazer a instalação desses pacotes separadamente. Vou postar novamente aqui.

    Abs.

    1. O unixodbc:

    http://www.unixodbc.org/

    Na seção downloads, baixe a ultima versão

    2. E o mysql-conector-odbc:

    http://www.mysql.com/products/connector/odbc/

    3. Copie o arquivo unixODBC-2.2.11.tar.gz para /:

    # cp /diretorio_de_download/unixODBC-2.2.11.tar.gz /

    4. Instale o pacote:

    # tar zxvf unixODBC-2.2.11.tar.gz
    # cd unixODBC-2.2.11/
    # ./configure
    # make
    # make install

    5. Faça o mesmo procedimento com o mysql-connector-odbc-3.51.12.tar.gz:

    # cp /diretorio_de_download/mysql-connector-odbc-3.51.12.tar.gz /
    # cd mysql-connector-odbc-3.51.12
    # ./configure
    # make
    # make install

    6. Libtool execute: apt-get install libcrypto++-dev libguile-ltdl-1 libltdl3 libltdl3-dev libtool-doc libtoolbar-java libtoolkit-perl libtool

  40. Esta correto tambem.

    É isso ai….

    abs

  41. De uma olhada nos comentarios do artigo, ja comentei sobre esse erro.

    Abs

  42. tente refazer a instalação.

    Abs

  43. Da uma olhada nos comentarios do artigo do Sun Virtual Box. La fala como colocar a placa de rede em modo bridge para poder pegar o mesmo ip da sua rede.

    Abs

  44. o unixodbc.org está fora do ar.

    Para baixar o unixodbc, podemo usar o seguinte end: http://sourceforge.net/projects/unixodbc/files/unixODBC/2.3.0/unixODBC-2.3.0.tar.gz/download

  45. Amigo,

    Parabéns pelo post mas tentei instalar o pacote dessa segunda video aula e apresentou erro.

    Impossivel encontrar o initrd-tools

    Abraço

  46. boa tarde Adriano
    to tendo algumas dificuldades na parte 2 na instalacao de pacotes apt-get 2 dos pacotes nao tem nos repositorios initrd-tools e mysql-connector-odbc

  47. 1000 desculpas nao tinha observado que ja tinha resposta para isso

    mas mesmo assim no mysql-connector-odbc-5.1.7.tar.gz
    fiz o seguinte

    wget http://mysql.he.net/Downloads/Connector-ODBC/5.1/mysql-connector-odbc-5.1.7.tar.gz

    tar zxvf mysql-connector-odbc-5.1.7.tar.gz

    cd mysql-connector-odbc-5.1.7

    ./configure <– ate aqui blz

    make <– make: *** Nenhum alvo indicado e nenhum arquivo make encontrado. Pare.

    make install

    diretorio
    pabx:/usr/src/mysql-connector-odbc-5.1.7# dir
    acinclude.m4 CreateBinaryMsi.bat LICENSE.gpl resource.h
    aclocal.m4 CreateBinaryZip.bat ltmain.sh scripts
    BUILD.unix CreateSourceZip.bat Makefile.am setup
    BUILD.win depcomp Makefile.in setupgui
    ChangeLog dltest missing test
    cmake doc MYODBC_CONF.h Uninstall.bat
    CMakeLists.txt driver MYODBC_MYSQL.h Upgrade.bat
    config.guess INSTALL MYODBC_ODBC.h util
    config.log Install.bat mysql.bmp VersionInfo.h
    config.sub installer qt.m4 wix
    configure install-sh README
    configure.in INSTALL.win README.debug

  48. Boa noite, estou seguindo seu tutorial, mas estou usando o debian 5.06 a versão mais recente e estou tentando usar o apt-get do tutorial mais ele não deixa instalar fala de erro no initrd-tools eu retirei ele do apt get mais informa que outros pacotes tem versão mais recente disponivel.
    Tem como você me mandar o apt-get dos pacotes que será necessário para usar nesta versão?

    Obrigado e parabéns pelo tutorial.

  49. Da uma lida nos comentários, mas de qualquer maneira retire esse pacote da lista e rode o comando novamente.

    Abs

Deixe um comentario